SYNAQ Securemail Incident - 11/02/2020
Incident Report for SYNAQ
Resolved
Dear Clients,

The SYNAQ Securemail issue has been resolved and the service has returned to optimal functionality
Posted Feb 11, 2020 - 14:28 CAT
Investigating
Dear Clients,

SYNAQ Securemaili is currently experiencing an issue where inbound mails are delayed. Engineers are investigating the issue as a matter of urgency.
Posted Feb 11, 2020 - 14:03 CAT
This incident affected: SYNAQ Securemail.