Cloud Mail Incident - 11/12/2020
Incident Report for SYNAQ
Resolved
SYNAQ Cloud Mail services are now fully restored and running optimally.
Posted Dec 11, 2020 - 15:17 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is current experiencing an issue where users are unable to authenticate and send mail. Engineers are investigating as a matter of urgency.
Posted Dec 11, 2020 - 14:42 CAT
This incident affected: SYNAQ Cloud Mail.