SYNAQ Securemail Issue - 14/05/2021
Incident Report for SYNAQ
Resolved
Dear Clients,

The SYNAQ Securemail issue has been resolved and the service has returned to optimal functionality.
Posted May 14, 2021 - 16:56 CAT
Investigating
Dear Clients,

SYNAQ Securemail is currently experiencing an issue where certain mails sent to O365 are experiencing delays in delivery. Engineers are investigating this as a matter of urgency.
Posted May 14, 2021 - 12:42 CAT
This incident affected: SYNAQ Securemail.