SYNAQ Cloud Mail Incident - 03/12/2020
Incident Report for SYNAQ
Resolved
Dear Clients,

The SYNAQ Cloud Mail issue has been resolved and the service has returned to optimal functionality.
Posted Dec 03, 2020 - 16:40 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is currently experiencing an partial issue where some users are unable to log into their mailboxes. Engineers are investigating the issue as a matter of urgency.
Posted Dec 03, 2020 - 16:20 CAT
This incident affected: SYNAQ Cloud Mail.