SYNAQ Cloud Mail Incident
Incident Report for SYNAQ
Resolved
Dear Clients,

The SYNAQ Cloud Mail Incident has been resolved and the service has returned to optimal functionality.
Posted Sep 28, 2020 - 15:06 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is currently experiencing an issue affecting a subset of users from logging into the platform. Engineers are investigating as a matter of urgency.
Posted Sep 28, 2020 - 13:44 CAT
This incident affected: SYNAQ Cloud Mail.