Cloud Mail Incident - 2021/03/12
Incident Report for SYNAQ
Postmortem

Summary and Impact to Customers

On Friday 12th March 2021 from 07:52 to 14:45, SYNAQ Cloud Mail experienced a mail authentication incident.

The resultant impact of the event was that users using ActiveSync to authenticate could not access the platform.

Root Cause and Solution

The root cause of this event was due to an error with the license for the ‘Next Generation’ mobile module, deployed at the beginning of February. The license failed to validate against the upstream licensing server and went into an automatic grace period. This grace period only lasts for 20 days and once the 20-day period had expired, the mobile module was no longer responding to authentication requests from ActiveSync. This was tested in staging and pre-production and passed tests successfully as this was not left to run past the 20-day grace period.

In order to resolve this issue, a license that had been validated against the license server was deployed. Once deployed, authentication requests via ActiveSync resumed.

Remediation Actions

• A permanent fix to correct these validation issues will be released in the next patch which will be rolled out to our servers following our extensive testing process.

• New monitoring alerts are being reviewed to be able to detect if these licenses move into the grace period again.

Posted Mar 24, 2021 - 09:17 CAT

Resolved
Dear Clients,

The SYNAQ Cloud Mail incident has been resolved and the service has returned to optimal functionality.
Posted Mar 12, 2021 - 14:45 CAT
Update
Dear Clients,

The SYNAQ Cloud Mail incident has been resolved and the service has returned to optimal functionality.
Posted Mar 12, 2021 - 14:45 CAT
Update
Dear Clients,

Our engineers are still working on the resolution of the SYNAQ Cloud Mail issue. This is being treated as a matter of urgency.

We will send our next update in 60 minutes.
Posted Mar 12, 2021 - 13:03 CAT
Identified
We have Identified the cause of the incident with our upstream vendor, and a fix is underway.
Please note this incident affects only a subset of users using ActiveSync for mobile device access.
You may still access email using webmail, IMAP and POP3.
Posted Mar 12, 2021 - 11:52 CAT
Update
Dear Clients,

Our engineers are still investigating the SYNAQ Cloud Mail incident. Please be assured that we have this under control and are treating this as a top priority.

We will send our next update in 60 minutes.
Posted Mar 12, 2021 - 10:21 CAT
Update
Dear Clients,

Our engineers are still investigating the SYNAQ Cloud Mail incident. Please be assured that we have this under control and are treating this as a top priority.

We will send our next update in 60 minutes.
Posted Mar 12, 2021 - 09:08 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is currently experiencing an incident where users are unable to access their mail via their mobile devices. Engineers are investigating this as a matter of urgency.

We will send our next update in 60 minutes.
Posted Mar 12, 2021 - 07:52 CAT
This incident affected: SYNAQ Cloud Mail.