SYNAQ Cloud Mail Incident - 11/12/2020
Incident Report for SYNAQ
Resolved
Dear Clients,

SYNAQ Cloud Mail services are now fully restored and running optimally.
Posted Dec 11, 2020 - 13:47 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is currently experiencing an issue where some users are unable to login and send mail. Webmail is unaffected. Engineers are investigating the issue as a matter of urgency.
Posted Dec 11, 2020 - 12:46 CAT
This incident affected: SYNAQ Cloud Mail.