SYNAQ Cloud Mail Incident - 10/10/2019
Incident Report for SYNAQ
Resolved
SYNAQ Cloud Mail services have been fully restored.
Posted 8 days ago. Sep 10, 2019 - 11:09 CAT
Investigating
Dear Clients. SYNAQ Cloud Mail is currently experiencing degraded performance affecting a subset of mailboxes and delays sending and receiving certain mails. Engineers are currently investigating the issue.
Posted 8 days ago. Sep 10, 2019 - 08:48 CAT
This incident affected: SYNAQ Cloud Mail.