SYNAQ Cloud Mail - Mail Delay
Incident Report for SYNAQ
Resolved
SYNAQ Cloud Mail Services have been fully restored and mail flow has returned to normal.
Posted 10 months ago. Feb 03, 2017 - 14:14 CAT
Investigating
SYNAQ Cloud Mail is currently experiencing an intermittent mail delay of up to 25 minutes.
Engineers are currently investigating this issue as a matter of urgency.
Posted 10 months ago. Feb 03, 2017 - 12:02 CAT
This incident affected: SYNAQ Cloud Mail.