Cloud Mail Outage 2017-11-14
Incident Report for SYNAQ
Resolved
The Cloud Mail incident has been resolved and all functionality is fully restored
Posted 7 months ago. Nov 14, 2017 - 22:03 CAT
Investigating
Cloud Mail incident, users unable to use active sync or webmail. Engineers are currently investigating.
Posted 7 months ago. Nov 14, 2017 - 21:06 CAT
This incident affected: SYNAQ Cloud Mail.