CloudMail Incident 2016-07-21
Incident Report for SYNAQ
Resolved
The incident has been resolved. We apologize for any inconvenience and an incident report will follow shortly.
Posted over 1 year ago. Jul 21, 2016 - 11:53 CAT
Investigating
CloudMail is current experiencing a incident causing mail delays, slow webmail and console access and time outs from mail clients
Posted over 1 year ago. Jul 21, 2016 - 11:00 CAT
This incident affected: SYNAQ Cloud Mail.