SYNAQ Securemail mail delays 28-04-2016
Incident Report for SYNAQ
Resolved
All mail delays have been resolved
Posted over 1 year ago. Apr 28, 2016 - 17:48 CAT
Investigating
SYNAQ Securemail Mail delays currently being experienced of up to 20 mins
Posted over 1 year ago. Apr 28, 2016 - 16:24 CAT
This incident affected: SYNAQ Securemail.